Topics

Xcode and device management.


Alex Zavatone
 

A few days ago, I noticed that my iOS devices which do not have automatic update enabled automatically updated themselves to iOS 14.2.

As I still have a fair amount of 32 bit software that I rely on, some of my macs are still running macOS 10.14.6 and Xcode 11.3, limiting the ability to build to a maximum of iOS 13.2 and not able to build directly to these devices.

I can’t be the only person who has this problem.

Do any of you out there have strategies for
- downgrading iOS to a specific version with an Apple supported IPSW?
- adding the libraries from Xcode 12.2 to a previous version of Xcode so that they can target iOS 14.2?

Thanks in advance.
Alex Zavatomne