Topics

Debugger showing variables as nil even if they are not?

Alexander von Below
 

Hello,

has anyone here witnessed this? The debugger shows variables as nil, even when print statements and the program execution clearly prove they are not.

I am seeing this regularly and repeatable in one project. Are there settings I can/should check? Is this a known issue?

Yes, I filed a feedback, but as the issue is hard to reproduce without sending the full project over, I wanted to ask here, too.

Thanks

Alex

Sandor Szatmari
 

I have seen this too. I did not try to figure it out though. Seen in Xcode version 8.2.1 and 9.4

What version of Xcode are you using?

Sandor

On Jan 9, 2020, at 10:12, Alexander von Below via Groups.Io <below=mac.com@groups.io> wrote:

Hello,

has anyone here witnessed this? The debugger shows variables as nil, even when print statements and the program execution clearly prove they are not.

I am seeing this regularly and repeatable in one project. Are there settings I can/should check? Is this a known issue?

Yes, I filed a feedback, but as the issue is hard to reproduce without sending the full project over, I wanted to ask here, too.

Thanks

Alex

Gary L. Wade
 

The Xcode team knows about the issue.
--
Gary L. Wade
http://www.garywade.com/

On Jan 9, 2020, at 7:17 AM, Sandor Szatmari <admin.szatmari.net@...> wrote:

I have seen this too. I did not try to figure it out though. Seen in Xcode version 8.2.1 and 9.4

What version of Xcode are you using?

Sandor

On Jan 9, 2020, at 10:12, Alexander von Below via Groups.Io <below=mac.com@groups.io> wrote:

Hello,

has anyone here witnessed this? The debugger shows variables as nil, even when print statements and the program execution clearly prove they are not.

I am seeing this regularly and repeatable in one project. Are there settings I can/should check? Is this a known issue?

Yes, I filed a feedback, but as the issue is hard to reproduce without sending the full project over, I wanted to ask here, too.

Thanks

Alex


Alexander von Below
 

Thanks!

Sandor: Current Stable Xcode 11.3 (11C29)

Am 09.01.2020 um 16:17 schrieb Sandor Szatmari <admin.szatmari.net@...>:

I have seen this too. I did not try to figure it out though. Seen in Xcode version 8.2.1 and 9.4

What version of Xcode are you using?

Sandor

On Jan 9, 2020, at 10:12, Alexander von Below via Groups.Io <below=mac.com@groups.io> wrote:

Hello,

has anyone here witnessed this? The debugger shows variables as nil, even when print statements and the program execution clearly prove they are not.

I am seeing this regularly and repeatable in one project. Are there settings I can/should check? Is this a known issue?

Yes, I filed a feedback, but as the issue is hard to reproduce without sending the full project over, I wanted to ask here, too.

Thanks

Alex


Sandor Szatmari
 

Thanks Gary!

On Jan 9, 2020, at 10:23, Gary L. Wade <garywade@...> wrote:

The Xcode team knows about the issue.
--
Gary L. Wade
http://www.garywade.com/

On Jan 9, 2020, at 7:17 AM, Sandor Szatmari <admin.szatmari.net@...> wrote:

I have seen this too. I did not try to figure it out though. Seen in Xcode version 8.2.1 and 9.4

What version of Xcode are you using?

Sandor

On Jan 9, 2020, at 10:12, Alexander von Below via Groups.Io <below=mac.com@groups.io> wrote:
Hello,

has anyone here witnessed this? The debugger shows variables as nil, even when print statements and the program execution clearly prove they are not.

I am seeing this regularly and repeatable in one project. Are there settings I can/should check? Is this a known issue?

Yes, I filed a feedback, but as the issue is hard to reproduce without sending the full project over, I wanted to ask here, too.

Thanks

Alex