Big Sur Terminal editing weirdness


 



On Apr 30, 2021, at 10:20 AM, dhoerl via groups.io <dhoerl@...> wrote:

Took me forever to track it down, but Terminal (at least for me) is not setting "COLUMNS", so it defaults to 80.

(Sorry to wake up this thread, but)

I just checked Terminal.app in my macOS 11.3 system, and $COLUMNS is set correctly and updates after I resize the window.
Sounds like something weird happening on your setup, maybe an obscure pref or something your shell is messing with? Best file a bug report.

—Jens


Alex Zavatone
 

Glad that they have good QA.

On Apr 30, 2021, at 12:20 PM, dhoerl via groups.io <dhoerl=mac.com@groups.io> wrote:

I ues "vi" mode in my shell to edit command lines - but since I updated to Big Sur (or was it an M1?), sometimes when I'd edit a line the cursor would go back a line.

Took me forever to track it down, but Terminal (at least for me) is not setting "COLUMNS", so it defaults to 80.

In previous releases, the shell would get the set and updated as Terminal windows resized.

Posting this in case someone else has the same puzzling issues.

BTW my fix was to just set COLUMNS to 512 in my profile. But really...






dhoerl
 

I ues "vi" mode in my shell to edit command lines - but since I updated to Big Sur (or was it an M1?), sometimes when I'd edit a line the cursor would go back a line.

Took me forever to track it down, but Terminal (at least for me) is not setting "COLUMNS", so it defaults to 80.

In previous releases, the shell would get the set and updated as Terminal windows resized.

Posting this in case someone else has the same puzzling issues.

BTW my fix was to just set COLUMNS to 512 in my profile. But really...