Date   

Re: Xcode 11 unusable?

 

I assume this happens in any Xcode project and not just your own?

Open Console.app and check various logs to see if anything Xcode-related is being dumped.
Sample Xcode (using Activity Monitor or the 'sample' tool) and see if it's spending a ton of time in something suspicious-looking.
Definitely submit a bug report to Apple. The Feedback app will collect a profile.

—Jens


Re: Xcode 11 unusable?

Alex Zavatone
 

If you’re allowed to share any of the stuff that crashes with me, I’ve got a few versions of the OS and Xcode 11 installed on a few of my Macs and can see if I can open them.

Feel free to email me off list if you want.  

Cheers.  Gotta love Xcode. : /

On May 10, 2020, at 12:50 PM, Leo <leo.r@...> wrote:

On Sun, May 10, 2020 at 10:42 AM, Alex Zavatone wrote:
It’s been reported on Reddit that this is a problem in projects that have mixed Objective-C and Swift code in Xcode 11.
 
No Swift in my projects, Objective-C only


Re: Xcode 11 unusable?

Leo
 

On Sun, May 10, 2020 at 10:42 AM, Alex Zavatone wrote:
It’s been reported on Reddit that this is a problem in projects that have mixed Objective-C and Swift code in Xcode 11.
 
No Swift in my projects, Objective-C only


Re: Xcode 11 unusable?

Alex Zavatone
 

It’s been reported on Reddit that this is a problem in projects that have mixed Objective-C and Swift code in Xcode 11.

On May 10, 2020, at 12:31 PM, Leo <leo.r@...> wrote:

Only Xcode 11 is affected. Everything else including Xcode 10 works normally.

I don't have any Xcode extensions.

I also tried:

-Creating a new clean user and run Xcode 11 there
-Restarting in safe mode.

Absolutely the same things happen.


Leo 


Re: Xcode 11 unusable?

Leo
 

Only Xcode 11 is affected. Everything else including Xcode 10 works normally.

I don't have any Xcode extensions.

I also tried:

-Creating a new clean user and run Xcode 11 there
-Restarting in safe mode.

Absolutely the same things happen.


Leo 


Re: Xcode 11 unusable?

Sak Wathanasin
 



On 10 May 2020, at 08:54, Leo <leo.r@...> wrote:

Then scrollers stop working normally, clicks get performed after delay, tabs are unresponsive etc. Then the clicks I performed earlier with no effect, start executing one after another. It's like I'm testing an early alpha of a new release.


When it is in this state, are other apps affected or is the issue only with Xcode? Something in the main thread getting wedged from the sound of it. Misbehaving Xcode extension?

Sak


Re: Xcode 11 unusable?

Leo
 

Reinstalling didn't help...

It's like the app works normally - until I open a .xib file. Then everything gradually goes to hell.

Even during few initial successful operations in IB it's clear that something isn't right. The cursor makes some strange flickering when moved over objects. 

Then scrollers stop working normally, clicks get performed after delay, tabs are unresponsive etc. Then the clicks I performed earlier with no effect, start executing one after another. It's like I'm testing an early alpha of a new release.


Leo


Re: Xcode 11 unusable?

Leo
 

Thanks Sak,

Neither Siri no derived data helped so far. Other apps seem to work normally - including Xcode 10.

I'll update if find any solution.

Leo


Re: Xcode 11 unusable?

Peter Hudson
 

I’d be inclined to remove the install of xcode and re install. 

Peter

On 10 May 2020, at 07:45, Leo <leo.r@...> wrote:

Thanks Peter,

Deleted derived data didn't help... Plus I discovered yet more issues in IB. Xcode 11 cannot be used at all.

I'll keep looking for solution...

Leo


Re: Xcode 11 unusable?

Leo
 

Thanks Peter,

Deleted derived data didn't help... Plus I discovered yet more issues in IB. Xcode 11 cannot be used at all.

I'll keep looking for solution...

Leo


Re: Xcode 11 unusable?

Sak Wathanasin
 

On 8 May 2020, at 06:16, Leo <leo.r@...> wrote:

I just finally updated to Catalina and installed Xcode 11 (all latest versions of course).

Xcode 11 is totally non-responsive.

Just Xcode? I had similar issues after "upgrading" to Catalina - everything was laggy. What I later found out was that I had SIRI disabled (in Mojave before the u/g), and Catalina seems to need SIRI enabled to init or update something. After I enabled it, restarted, Catalina started behaving, and then I could turn it off. May be totally unrelated to your issue though.

The only similar behaviour to yours that I saw was delays when a breakpoint tripped - seemed to be much longer before you got the backtrace etc & the UI was responsive again. Nuking "DerivedData" seemed to help.

Regards
Sak



Re: Xcode 11 unusable?

Peter Hudson
 

Hi Leo

I had the same problem regarding code completion - the solution was to ditch the derived data for the project and to clean the build. ( someone on this list suggested I try this )

Regarding Interface Builder: from 11 onwards it’s run like treacle. I’ve never been able to find out why. 
My project code line was started 20 years ago and uses  .nib files. Some are very deep and complex - maybe this affects things. Simpler ones are just a bit tardy. 

Peter

On 8 May 2020, at 06:16, Leo <leo.r@...> wrote:

Is it just my luck - or is Xcode 11 unusable?

I just finally updated to Catalina and installed Xcode 11 (all latest versions of course).

Xcode 11 is totally non-responsive.

In Interface Builder, when I click elements they're not selected right away but after a brief delay. And then it takes several seconds until the info in the inspector updates.

Same thing in the code: everything happens after a brief delay. Code completion doesn't work at all.

Restarted Mac, quit Xcode several times - same thing in all project.


Xcode 10 works with no issues.


iMac 2017 27", 40 GB RAM

Any ideas?

Thanks,
Leo


Xcode 11 unusable?

Leo
 

Is it just my luck - or is Xcode 11 unusable?

I just finally updated to Catalina and installed Xcode 11 (all latest versions of course).

Xcode 11 is totally non-responsive.

In Interface Builder, when I click elements they're not selected right away but after a brief delay. And then it takes several seconds until the info in the inspector updates.

Same thing in the code: everything happens after a brief delay. Code completion doesn't work at all.

Restarted Mac, quit Xcode several times - same thing in all project.


Xcode 10 works with no issues.


iMac 2017 27", 40 GB RAM

Any ideas?

Thanks,
Leo


Re: No Team ID, not a platform binary

Carl Hoefs
 

I enabled "Hardened Runtime" on the library, but it didn't fix the problem.

It does no I/O, only computation on some input values, and returns a double. Straight C code.
Since Xcode knows it's creating a dylib, wouldn't it set the necessary entitlements?
Does the same signing scenario apply to .a libs?

-Carl


Re: No Team ID, not a platform binary

Jack Brindle
 

It will need hardened runtime at the least. It also may need an exception that allows other apps to use the library. I don’t know if it needs Notarization - since it is a dylib and not a framework I tend to doubt it can be notarized.

Jack


On May 5, 2020, at 8:20 PM, Carl Hoefs <newslists@...> wrote:

Does the library need certain entitlements? I have it set to "Apple Development" as the Code Signing Identity. Signing is set to automatic.

-Carl


Re: No Team ID, not a platform binary

Carl Hoefs
 

Does the library need certain entitlements? I have it set to "Apple Development" as the Code Signing Identity. Signing is set to automatic.

-Carl


Re: No Team ID, not a platform binary

Alex Zavatone
 

Look at the General Info or Code Signing section of the target.

On May 5, 2020, at 7:59 PM, Carl Hoefs <newslists@autonomy.caltech.edu> wrote:

I've created a dynamic C library, libgauss.dylib, and copied it into /usr/local/lib.

My MacOS 10.14 app builds fine against it, but won't run, complaining that the library doesn't have a "Team ID" and is not a "platform binary".

What does this mean? How can I set this to work?

-Carl




dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /usr/local/lib/libgauss.dylib
Referenced from: /Users/USER/NIHProject/*/NIHGauss.app/Contents/MacOS/NIHGauss
Reason: no suitable image found. Did find:
/usr/local/lib/libgauss.dylib: code signature in (/usr/local/lib/libgauss.dylib) not valid for use in process using Library Validation: mapping process has no Team ID and is not a platform binary
/usr/local/lib/libgauss.dylib: stat() failed with errno=1
/usr/local/lib/libgauss.dylib: code signature in (/usr/local/lib/libgauss.dylib) not valid for use in process using Library Validation: mapping process has no Team ID and is not a platform binary



No Team ID, not a platform binary

Carl Hoefs
 

I've created a dynamic C library, libgauss.dylib, and copied it into /usr/local/lib.

My MacOS 10.14 app builds fine against it, but won't run, complaining that the library doesn't have a "Team ID" and is not a "platform binary".

What does this mean? How can I set this to work?

-Carl




dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /usr/local/lib/libgauss.dylib
Referenced from: /Users/USER/NIHProject/*/NIHGauss.app/Contents/MacOS/NIHGauss
Reason: no suitable image found. Did find:
/usr/local/lib/libgauss.dylib: code signature in (/usr/local/lib/libgauss.dylib) not valid for use in process using Library Validation: mapping process has no Team ID and is not a platform binary
/usr/local/lib/libgauss.dylib: stat() failed with errno=1
/usr/local/lib/libgauss.dylib: code signature in (/usr/local/lib/libgauss.dylib) not valid for use in process using Library Validation: mapping process has no Team ID and is not a platform binary


Re: How to add a 32-bit binary to a bundle in Catalina/Xcode 11.4.1?

John Brownie
 

Thank you to all who responded. It's great to have such a useful group of people available!

Putting the binary into a Run Script phase works nicely. Since I already had a post-build Run Script phase to sign certain things, I was able to put the copy into that script. It built fine, archived, and notarised successfully. So I'm back to being productive without having to try to set up a Mojave environment for the build process.

John
--
John Brownie
Mussau-Emira language, New Ireland Province, Papua New Guinea
Kouvola, Finland


Re: How to add a 32-bit binary to a bundle in Catalina/Xcode 11.4.1?

John Brownie
 

Thanks for the suggestions. I'll try a script phase when I get back to it tomorrow, and report back.

John

Leo wrote on 19/4/20 05:01:

yeahh of course it's the RUN SCRIPT not Copy phase... just correcting myself. that's what i also meant in my earlier post - to use a script to copy whatever John needs from wherever during a build phase. although i don't know if it'll help in this particular case anyway...

thanks,
Leo

--
John Brownie
Mussau-Emira language, New Ireland Province, Papua New Guinea
Kouvola, Finland

381 - 400 of 1447