Re: Problems with exporting an archived app


John Brownie
 

Glenn L. Austin wrote on 11/2/21 17:03:
Yes, M1 requires Xcode 12.
I got it to work by archiving in Xcode 12, then doing the distribute from Xcode 11.
I haven't done any QL plugins, but it's entirely possible that there's a bug in Xcode 12 where it's not recognizing the "older" QL structure.
Seems to be something like that.
I've got several versions of Xcode on my machine, and have never had to do the uninstall/reinstall dance - I either "xcode-select" the one I need if I'm going to working with it for a longer period of time, or if I'm just doing a couple of command-line processes, I "export DEVELOPER_DIR=" to the Xcode path. The "xcode-install" gem helps a lot with that as well.
I'm always pressed for space on my computer, so I don't have enough spare space to have both versions installed. If this persists, I may have to work out what I can move to an external disk and have both available.

John
--
John Brownie
Mussau-Emira language, New Ireland Province, Papua New Guinea
Kouvola, Finland

Join xcode@apple-dev.groups.io to automatically receive all group messages.