Manually-shown palettes not showing during app restoration


Steve Mills
 

I needed to add many attributes to my CoreData model. Filling in these attributes will happen during migration of old docs, which means loading all the files that each asset points to. Since it can take a while to do all this, I'm putting up a progress palette so the user knows something is happening. This works fine.

What does NOT work fine is when migration happens during app restoration. The palette says its window is loaded and the frame is correct, but it's just not appearing onscreen. Does app restoration do some kind of window manager voodoo that prevents windows NOT being restored from appearing? Maybe so it doesn't confuse the list of windows being restored?

--
Steve Mills
Drummer, Mac geek


Steve Mills
 

On May 18, 2020, at 10:29:13, Steve Mills via groups.io <sjmills=mac.com@groups.io> wrote:

I needed to add many attributes to my CoreData model. Filling in these attributes will happen during migration of old docs, which means loading all the files that each asset points to. Since it can take a while to do all this, I'm putting up a progress palette so the user knows something is happening. This works fine.

What does NOT work fine is when migration happens during app restoration. The palette says its window is loaded and the frame is correct, but it's just not appearing onscreen. Does app restoration do some kind of window manager voodoo that prevents windows NOT being restored from appearing? Maybe so it doesn't confuse the list of windows being restored?
Screw it. I've switched the migration progress window to a regular window and now present it modally. This kind of window WILL appear during state restoration, unlike a palette which has been sent orderFront.

--
Steve Mills
Drummer, Mac geek