Double clicking sigle entry Table not working.

Brian Christmas

G’day all

First, I fixed my lasr error bu methodically going over every deatil, and discovered a Text Field Cell in a Text Field has somehow been assigned a value, linked to an array controller, with ‘self’ as the Model Key Path.

Don’t know how it happened. I was very tired, but knowe I cannot sleep until I’ve solved any problems. I AM finding some unusual tthing being added/altered in Xcode 8 sometimes. Don’t know id it’s me, or a bug?

However, this problem is text book ‘Explored’ ebook code, that’s not working.

I built a Table, with Double Clicking access,  theTableOne's setDoubleAction:"displaySelection:" -- so double-click will call action handler

Worked fine with multiple entries, then I added a column, reduced the files to the only one containing 4 items of data, and now a Double Click on the single line, which is always hilited, refuses to work. Refuses to call the handler.

1. Would the fact the line is hilited in blue make a difference?

2. Is this a bug?